Hallo Gast

Fout 35 bij installeren plugin Woocommerce

  • 9 Reacties
  • 3159 Gelezen
Fout 35 bij installeren plugin Woocommerce
« Gepost op: 01 januari, 2017, 20:22:44 »
Ik krijg de volgende fout nadat ik de juiste gegevens heb ingevoerd bij de instellingen in Wordpress / Woocommerce: "Fout 35: SSL connect error (curl_exec() (Curl: 7.19.7 (ssl: NSS/3.13.6.0; zlib: 1.2.3)))".

Meer info:
Application: Acumulus module 4.6.6; Library: 4.6.6; Shop: WooCommerce 2.6.9 (WordPress: 4.7);
Environment: PHP 5.4.26; Curl: 7.19.7 (ssl: NSS/3.13.6.0; zlib: 1.2.3); JSON: 1.2.1; OS: Linux srv19913.flexwebhosting.nl 2.6.32-042stab120.3 #1 SMP Thu Oct 20 18:18:21 MSK 2016 x86_64.

Ben benieuwd wat hier misgaat.

*

Guido

  • 2112
    • Bekijk profiel
Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #1 Gepost op: 02 januari, 2017, 10:03:21 »
Ik denk dat er een configuratieprobleempje zou kunnen zijn voor de webshop die je gebruikt. Kun je het adres van de webwinkel even doorgeven?

Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #2 Gepost op: 02 januari, 2017, 21:12:44 »
Bedankt voor je reactie Guido. Het adres is https://www.ecorijk.nl.

*

Guido

  • 2112
    • Bekijk profiel
Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #3 Gepost op: 02 januari, 2017, 21:34:09 »
Ik zou je webhoster eens vragen om het certificaat iets netter op te zetten. Ik vermoed dat onze API de aangeboden versleuteling niet goed genoeg vind. Zie ook: https://www.ssllabs.com/ssltest/analyze.html?d=www.ecorijk.nl

Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #4 Gepost op: 03 januari, 2017, 22:05:33 »
Hi Guido,

M'n hostingprodiver geeft aan de configuratie van het certificaat te hebben verbeterd. Volgens mij zie ik ook wat meer groen bij https://www.ssllabs.com/ssltest/analyze.html?d=www.ecorijk.nl. :) Maar helaas krijg ik nog dezelfde foutmelding in de plugin. Wellicht heb je nog wat tips? Of zie je nog meer ruimte voor verbetering in de configuratie van het certificaat?

*

Guido

  • 2112
    • Bekijk profiel
Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #5 Gepost op: 03 januari, 2017, 22:23:10 »
Het ziet er inderdaad iets beter uit. Stempel er op en door naar balie #2,... ik herinner me vaag dat iemand anders dit ook had.. daar was de website een (te) oude versie van curl aan het gebruiken. Kun je eens uitzoeken of navragen welke versie van curl er gebruikt wordt en of er een OS-update voor uitgerold kan worden?

Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #6 Gepost op: 05 januari, 2017, 19:59:34 »
Guido,

De hostingprovider heeft wat aanpassingen doorgevoerd. De foutmelding is gewijzigd van
"Fout 35: SSL connect error (curl_exec() (Curl: 7.19.7 (ssl: NSS/3.13.6.0; zlib: 1.2.3)))"
naar
"Fout 77: Problem with the SSL CA cert (path? access rights?) (curl_exec() (Curl: 7.19.7 (ssl: NSS/3.13.6.0; zlib: 1.2.3)))".

Ik krijg de vraag: "Naar welke URL maakt u verbinding, mogelijk kan ik zelf daarmee ook testen en troubleshooten.".
Kun je dit delen met me?

*

Guido

  • 2112
    • Bekijk profiel
Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #7 Gepost op: 06 januari, 2017, 11:20:36 »
De koppelingen maken allemaal een verbinding naar https://api.sielsystems.nl/

Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #8 Gepost op: 09 januari, 2017, 19:23:06 »
Guido,

Er zijn wat aanpassingen doorgevoerd binnen PHP, en daarmee lijkt het te zijn opgelost. Even afwachten tot de koppeling daadwerkelijk een keer gaat lopen bij een bestelling. Geen nieuws is wat dat betreft goed nieuws dan, dus dit ticket kan gesloten worden.

Bedankt voor je hulp!

*

Guido

  • 2112
    • Bekijk profiel
Re: Fout 35 bij installeren plugin Woocommerce
« Reactie #9 Gepost op: 09 januari, 2017, 19:25:17 »
Mooi. Ik ben benieuwd maar vermoed dat de certificaten en certificate-authorities op de server zijn bijgewerkt. Mocht iemand ooit tegen fout #35 aanlopen dan is dit wellicht een praktische case om na te slaan.