Hallo Gast

Error 35: TCP connection reset by peer / SSL connect error

  • 0 Reacties
  • 967 Gelezen
Error 35: TCP connection reset by peer / SSL connect error
« Gepost op: 26 september, 2017, 09:53:11 »
Vanwege veiligheidsredenen accepteert de Acumulus web service sinds 19 september 2017 alleen nog maar met TLS 1.2 beveiligde verbindingen. Deze versie wordt door de meeste systemen waar uw webwinkel op kan draaien ondersteund. Echter het blijkt dat er een aantal systemen zijn die toch kiezen voor een oudere versie, zelfs als ze deze meest recente versie wel ondersteunen. Dit uit zich via foutmeldingen als

- Bij het verzenden van een factuur naar Acumulus is er een ernstige fout opgetreden. De factuur is misschien aangemaakt, controleer dit in Acumulus zelf.
- Ernstige Fout 35: curl_exec()

Om dit op te lossen zijn er nieuwe versies (4.9.0) van de webshopkoppelingen voor HikaShop, Magento, OpenCart, PrestaShop, VirtueMart en WooCommerce uitgebracht. Deze zijn te downloaden via dit forum. Voor WooCommerce verschijnt deze nieuwe versie (4.9.1!!! die ook de compatibiliteit met WordPress 4.8.2 herstelt) vanzelf in uw admin Dashboard.


Speciaal voor OpenCart gebruikers:
Deze nieuwe versie ondersteunt nu ook OpenCart 3, maar niet meer OpenCart 2.0 en 2.2. Als u dit probleem voor deze versies wilt oplossen raden wij u aan om te upgraden naar OpenCart 2.3. Als dat niet mogelijk is vanwege te veel aanpassingen voeg dan deze regels toe aan het bestand system/library/Siel/Acumulus/Web/Communicator.php, method sendHttpPost(), regel 214:

            // Since 2017-09-19 the Acumulus web service only accepts TLS 1.2.
            // Apparently, some libraries do support this version but do not use
            // it by default, so we force it.
            CURLOPT_SSLVERSION => CURL_SSLVERSION_TLSv1_2,


Het volledige statement wordt dan:

        // Configure the curl connection.
        $options = array(
            CURLOPT_URL => $uri,
            CURLOPT_RETURNTRANSFER => true,
            CURLOPT_SSL_VERIFYPEER => false,
            CURLOPT_POST => true,
            CURLOPT_POSTFIELDS => $post,
            // Since 2017-09-19 the Acumulus web service only accepts TLS 1.2.
            // Apparently, some libraries do support this version but do not use
            // it by default, so we force it.
            CURLOPT_SSLVERSION => CURL_SSLVERSION_TLSv1_2,
            //CURLOPT_PROXY => '127.0.0.1:8888', // Uncomment to debug with Fiddler.
        );

« Laatst bewerkt op: 26 september, 2017, 14:11:30 door erwin-burorader »