Hallo Gast

Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder

  • 7 Reacties
  • 495 Gelezen
Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Gepost op: 20 november, 2018, 15:43:08 »
Beste mensen,

 ik zag in admin van wordpress bij de webshopkoppeling de mededeling dat mijn beheerderaccount verouderd is en dat ik beter verander naar een API account. Dat heb ik gedaan door mijn bestaande beheeraccount in de web-acumulus te wijzigen naar API-beheerder. Toen kwam de mededeling in de webshopkoppeling dat ik beter geen API-beheerderaccount gebruik maar een API-gebruikeraccount. Dat heb ik geprobeerd te wijzigen in de web-acumulus maar dat lukte niet. Toen geprobeerd om een nieuw account te maken met API-gebruikers bevoegdheden. Dat lukte ook niet omdat er iets misging met bevoegdheden.

Graag advies over wat te doen.

Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #1 Gepost op: 20 november, 2018, 20:06:53 »
Ging het mis in Acumulus of in de plugin? Enne, de eerste melding geeft al aan dat je naar een rol API-Gebruiker moet overstappen ;)

Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #2 Gepost op: 21 november, 2018, 09:14:22 »
Ik ben erg onhandig in dit soort zaken, dus bij mij ging het in beiden mis. In zoverre dat ik in Acumulus last had met het wijzigen van de rol en later ook met de nieuwe gebruiker. Bovendien bleef ik foutmeldingen houden in de plugin. Ik weet dus niet waar het fout gaat en wat ik nu als eerste moet doen.

Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #3 Gepost op: 21 november, 2018, 09:49:18 »
 Ook emails met meldingen, nu en gisteren :

553 - Warning: You are using a deprecated user role to connect to the Acumulus API. Please add another user with an API-compliant role or change the role for the current user. - XUPR7NEC8

401 - Error - Unauthorized - Authentication failed for provided credentials. 185.104.29.62. - UAEFAIL01

Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #4 Gepost op: 22 november, 2018, 10:54:33 »
Hallo Erwin,

kun je nog even kijken naar bijlage en me alsjeblieft uitleggen wat ik moet doen? Deze melding krijg ik na een doorzetten van een bestelling vanuit de plugin naar Acumulus met mijn hoofdaccount (die ik niet kan wijzigen). Ik spreek engels dus ik begrijp dat ik gebruik maak van een afgekeurde rol en dat ik het beste in het account dat ik gebruik naar een nieuwe rol van het juiste type verwissel (API-gebruiker, neem ik aan?) of een nieuwe gebruiker aanmaak.

Als ik de bestaande rol probeer te wijzigen naar API-gebruiker, dan krijg ik de mededeling dat de inlognaam reeds in gebruik is (zie bijlage). Als ik de inlognaam en het wachtwoord of één van tweeën wijzig, dan kan ik niet meer inloggen in Acumulus. Ik kom er dus niet uit en krijg wel steeds deze foutmelding.

Inmiddels draait de plugin op een nieuwe gebruiker met het API-gebruikertype, dus daar nu geen foutmeldingen meer.

Graag je hulp.

Groeten
Geert


Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #5 Gepost op: 22 november, 2018, 12:55:20 »
Acumulus zelf ken ik ook niet zo goed.  Als de plugin werkt, naar ik begrijp met een andere gebruiker, wat is dan nog het probleem ?  Dat je deze gebruiker niet kunt wijzigen, of niet verwijderen? Ik denk dat je de rol van het hoofdaccount niet kunt wijzigen, anders kun je je zelf buiten sluiten. Gebruik dit hoofdaccount dus voor het inloggen in Acumulus zelf en gebruik  het aangemaakte extra account  voor de plugin.

Ik hoop dat dit je vragen beantwoord, anders kunje beter even contact op nemen met de service desk van Acumulus, die weten dit ongetwijfeld beter uit te leggen en te verhelpen.

Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #6 Gepost op: 22 november, 2018, 13:46:59 »
Dank voor je antwoord.

Ik die het nu zoals je beschrijft : inloggen op Acumulus met mijn hoofdaccount en de plugin draait op het tweede account. En behalve die foutmelding 553, blijkt er dus wel een probleem te zijn want ik zie nu net dat de plugin tóch een probleem meldt : Fout 401: Error - Unauthorized - Authentication failed for provided credentials. 185.104.29.62. (UAEFAIL01), dus het tweede account werkt niet voor de plugin?

Een service desk, heeft Acumulus die dan? Alle links over support die ik kan vinden  wijzen naar Siel.

Of gaat dat via het forum ? Zo ja, dan bij deze het verzoek om support aan Bert-Jan Wiegeraad svp.

Groeten
Geert


Re: Supportverzoek Woocommerce webshopkoppeling en API gebruiker/beheerder
« Reactie #7 Gepost op: 22 november, 2018, 19:39:55 »
Als je support nodig hebt stuur j een mail naar Siel (de bedrijfsnaam, Acumulus is de productnaam) op klantenservice at acumulus punt nl of via https://www.siel.nl/contact/ of het daar genoemde telefoonnummer.

Fout 401 kan maar 1 oorzaak hebben: verkeerde combi van contractcode, gebruikersnaam en wachtwoord. controleer alle 3, wijzig het wachtwoord desnoods in Acumulus als je het niet meer zeker weet, en dan zou het moeten werken.